Zm-lookup-user-not-found

Revision as of 08:49, 2 June 2017 by Raunaq (talk | contribs) (Created page with "=zm lookup: user not found= {{KB|{{ZCS 8.7}}||}} The problem was the Proxy would direct the loading of the ZWC client bits to the wrong mailstore hosts and when it then rende...")

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

zm lookup: user not found

   KB 23225        Last updated on 2017-06-2  




0.00
(0 votes)
ZCS 8.7 Article ZCS 8.7

The problem was the Proxy would direct the loading of the ZWC client bits to the wrong mailstore hosts and when it then rendered the entire left side pane was missing.

I found this, in the nginx.log

2017/05/26 20:22:44 [warn] 20355#0: *38 zmauth: an error occurs during zm lookup: user not found:61333e88-d023-458b-81f2-07007ad01fe7, fall back to IPHASH to get the upstream route, client: 10.51.4.121:51552, server: webmail.example.org, request: "GET /service/zimlet/res/Zimlets-nodev_all.css?language=en&country=US&cosId=beee5c1e-e860-4000-876e-d235fbb0bd53 HTTP/1.1", host: "zmproxymta1.example.org", referrer: "https://zmproxymta1.example.org/zimbra/"
2017/05/26 20:22:45 [error] 20355#0: *32 zm lookup: an error is returned by zimbra lookup handler: user not found:61333e88-d023-458b-81f2-07007ad01fe7, client: 10.57.34.169:51546, server: webmail.example.org, request: "GET /zimbra/js/Contacts_all.js.zgz?v=141215153642 HTTP/1.1", host: "zmproxymta1.example.org", referrer: "https://zmproxymta1.example.org/zimbra/"

The issue was the below parameter

zimbraReverseProxyMailHostQuery '(|(zimbraMailDeliveryAddress=${USER})(zimbraMailAlias=${USER}))'


The default for this parameter is (|(zimbraMailDeliveryAddress=${USER})(zimbraMailAlias=${USER})(zimbraId=${USER}))


Resetting it to default solved the issue. Please note that restart of both Proxy and mailbox nodes is required for the changes to come into affect .

Jump to: navigation, search