Upgrade to 8.6 fails with "Error: assertion '-r/opt/zimbra/conf/my.cnf' failed"

Revision as of 14:45, 31 August 2018 by Shanxt (talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

Upgrade to 8.6 fails with "Error: assertion '-r /opt/zimbra/conf/my.cnf' failed"


   KB 23363        Last updated on 2018-08-31  




0.00
(0 votes)


Problem

After an upgrade, starting Zimbra services fails with the following error in /var/log/zimbra.log

Error: assertion '-r /opt/zimbra/conf/my.cnf' failed


Solution

This usually comes up when the store package is selected to be upgraded on a non-mailbox server.

For example if the server contains only the LDAP server on 8.0.8, and then during upgrade the mailbox store component is selected, the error comes up and the upgrade does not continue.

To fix this, remove the zimbra-store package using the OS' package manager.

For example, on Redhat/CentOS systems, first get the mailbox package name :

rpm -qa | grep zimbra-store

And then remove it:

rpm -e <package-name>
Verified Against: ZCS 8.6 Date Created: 2018-08-13
Article ID: https://wiki.zimbra.com/index.php?title=Upgrade_to_8.6_fails_with_%22Error:_assertion_%27-r/opt/zimbra/conf/my.cnf%27_failed%22 Date Modified: 2018-08-31



Try Zimbra

Try Zimbra Collaboration with a 60-day free trial.
Get it now »

Want to get involved?

You can contribute in the Community, Wiki, Code, or development of Zimlets.
Find out more. »

Looking for a Video?

Visit our YouTube channel to get the latest webinars, technology news, product overviews, and so much more.
Go to the YouTube channel »


Jump to: navigation, search