Ubuntu 6.10 (Edgy Eft) Shell Changes

 - This is archive documentation, which means it is not supported or valid for recent versions of Zimbra Collaboration.

The Zimbra install scripts use 'source'.

Newer versions of Ubuntu (I think Edgy was the first) use 'dash' as the shell which doesn't have 'source'.

You will come across errors in your install log like:

Creating SSL certificate...
*** Running as zimbra user: cd /opt/zimbra; zmcreatecert 

/opt/zimbra/bin/zmcreatecert: 27: source: not found

Change to using 'bash' and run install.sh and things should work:

sudo mv /bin/sh /bin/sh-old
sudo ln -s /bin/bash /bin/sh 

(You can also rm /bin/sh according to others)

Thanks to dudes on this forum post: http://www.zimbra.com/forums/showthread.php?t=6969&highlight=Initializing+ldap+TLS+error

Moroever, in a fresh Dapper install:

apt-get install libidn11  curl  fetchmail  libpcre3 libgmp3c2 libexpat1 libxml2 libstdc++5 openssl perl perl-modules
Verified Against: unknown Date Created: 3/8/2007
Article ID: https://wiki.zimbra.com/index.php?title=Ubuntu_6.10_(Edgy_Eft)_Shell_Changes Date Modified: 03/24/2015

Try Zimbra

Try Zimbra Collaboration with a 60-day free trial.
Get it now »

Want to get involved?

You can contribute in the Community, Wiki, Code, or development of Zimlets.
Find out more. »

Looking for a Video?

Visit our YouTube channel to get the latest webinars, technology news, product overviews, and so much more.
Go to the YouTube channel »

Jump to: navigation, search