Difference between revisions of "Template:PatchInstallation"

(Created page with "<!-- This is a TEMPLATE that requires parameters: - Version=<version-number> - Packages=<Block of text specifying the package version lineup. Mediawiki formatting...")
 
(Patch Installation)
 
(8 intermediate revisions by 4 users not shown)
Line 14: Line 14:
 
* Zimlet patches can include removing existing Zimlets and redeploying the patched Zimlet.
 
* Zimlet patches can include removing existing Zimlets and redeploying the patched Zimlet.
 
* Only files or Zimlets associated with installed packages will be installed from the patch.
 
* Only files or Zimlets associated with installed packages will be installed from the patch.
* Switch to user '''zimbra''' before using ZCS CLI commands.
+
* Switch to <code>zimbra</code> user before using ZCS CLI commands.
 
* '''Important!''' You cannot revert to the previous ZCS release after you upgrade to the patch.
 
* '''Important!''' You cannot revert to the previous ZCS release after you upgrade to the patch.
 
* '''Important Note for ZCS Setup with Local ZCS repository:''' Customers who have set up local ZCS repository should first update the local repository by following instructions in [https://wiki.zimbra.com/wiki/Zimbra_Collaboration_repository#Keep_the_local_Repository_up_to_date wiki]
 
* '''Important Note for ZCS Setup with Local ZCS repository:''' Customers who have set up local ZCS repository should first update the local repository by following instructions in [https://wiki.zimbra.com/wiki/Zimbra_Collaboration_repository#Keep_the_local_Repository_up_to_date wiki]
Line 55: Line 55:
 
  zmproxyctl restart
 
  zmproxyctl restart
 
  zmmemcachedctl restart
 
  zmmemcachedctl restart
 +
 +
'''Install/Upgrade <code>zimbra-mta-components</code> on MTA node for FOSS and NETWORK'''
 +
* As <code>root</code>, first clear the yum cache and check for updates so the server sees all updated packages in the patch repository:
 +
yum clean metadata
 +
yum check-update
 +
* Then install the package:
 +
yum install zimbra-mta-components
 +
* Restart <code>amavisd</code> as <code>zimbra</code> user:
 +
su - zimbra
 +
zmamavisdctl restart
  
 
'''Install/Upgrade <code>zimbra-mta-patch</code> on MTA node for FOSS and NETWORK'''
 
'''Install/Upgrade <code>zimbra-mta-patch</code> on MTA node for FOSS and NETWORK'''
Line 69: Line 79:
 
  su - zimbra
 
  su - zimbra
 
  zmcontrol restart
 
  zmcontrol restart
 
'''Install/Upgrade <code>zimbra-chat</code> for FOSS'''
 
* As <code>root</code>, install the package:
 
yum install zimbra-chat
 
* Restart Zimbra mailbox service as <code>zimbra</code> user:
 
su - zimbra
 
zmmailboxdctl restart
 
  
 
'''Install/Upgrade <code>zimbra-talk</code> and <code>zimbra-network-modules-ng</code> (NETWORK Only)'''
 
'''Install/Upgrade <code>zimbra-talk</code> and <code>zimbra-network-modules-ng</code> (NETWORK Only)'''
Line 101: Line 104:
 
  su - zimbra
 
  su - zimbra
 
  zmmailboxdctl restart
 
  zmmailboxdctl restart
 +
 +
'''Install/Upgrade <code>Modern Web App Zimlets</code> (NETWORK Only)'''
 +
* Please refer [https://zimbra.github.io/zimbra-9/single-server-install.html#_installing_zimlets_for_modern_web_app here] for installing zimlets for Modern Web App.
 +
  
 
'''Upgrade OpenLDAP on LDAP node for FOSS and NETWORK'''
 
'''Upgrade OpenLDAP on LDAP node for FOSS and NETWORK'''
Line 143: Line 150:
  
 
''The installation of this patch is mandatory for the proxy to function on Ubuntu 18 servers.''
 
''The installation of this patch is mandatory for the proxy to function on Ubuntu 18 servers.''
 +
 +
'''Install/Upgrade <code>zimbra-mta-components</code> on MTA node for FOSS and NETWORK'''
 +
* As <code>root</code>, install package
 +
apt-get install zimbra-mta-components
 +
* Restart <code>amavisd</code> as <code>zimbra</code> user:
 +
su - zimbra
 +
zmamavisdctl restart
  
 
'''Install/Upgrade <code>zimbra-mta-patch</code> on MTA node for FOSS and NETWORK'''
 
'''Install/Upgrade <code>zimbra-mta-patch</code> on MTA node for FOSS and NETWORK'''
Line 158: Line 172:
 
  su - zimbra
 
  su - zimbra
 
  zmcontrol restart
 
  zmcontrol restart
 
'''Install/Upgrade zimbra-chat for FOSS'''
 
* As <code>root</code>, install package:
 
apt-get install zimbra-chat
 
* Restart Zimbra mailbox service as <code>zimbra</code> user:
 
su - zimbra
 
zmmailboxdctl restart
 
  
 
'''Install/Upgrade zimbra-talk and zimbra-network-modules-ng (NETWORK Only)'''
 
'''Install/Upgrade zimbra-talk and zimbra-network-modules-ng (NETWORK Only)'''
Line 188: Line 195:
 
  su - zimbra
 
  su - zimbra
 
  zmmailboxdctl restart
 
  zmmailboxdctl restart
 +
 +
'''Install/Upgrade <code>Modern Web App Zimlets</code> (NETWORK Only)'''
 +
* Please refer [https://zimbra.github.io/zimbra-9/single-server-install.html#_installing_zimlets_for_modern_web_app here] for installing zimlets for Modern Web App.
 +
  
 
'''Upgrade OpenLDAP on LDAP node for FOSS and NETWORK'''
 
'''Upgrade OpenLDAP on LDAP node for FOSS and NETWORK'''

Latest revision as of 10:19, 28 August 2020


Patch Installation

Please refer to the steps below to install {{{Version}}} on Redhat and Ubuntu platforms:

Before Installing the Patch

Before installing the patch, consider the following:

  • Patches are cumulative.
  • A full backup should be performed before any patch is applied. There is no automated roll-back.
  • Zimlet patches can include removing existing Zimlets and redeploying the patched Zimlet.
  • Only files or Zimlets associated with installed packages will be installed from the patch.
  • Switch to zimbra user before using ZCS CLI commands.
  • Important! You cannot revert to the previous ZCS release after you upgrade to the patch.
  • Important Note for ZCS Setup with Local ZCS repository: Customers who have set up local ZCS repository should first update the local repository by following instructions in wiki
  • Please make note that, installing the zimbra-patch package only updates the Zimbra core packages.

{{{Version}}} Packages

The package lineup for this release is:

{{{Packages}}}

Redhat

Installing Zimbra packages with system package upgrades

  • As root, first clear the yum cache and check for updates so the server sees there is a new zimbra-patch package in the patch repository:
yum clean metadata
yum check-update
  • Then ask yum to update available packages:
yum update
  • Restart ZCS as zimbra user:
su - zimbra
zmcontrol restart

Installing Zimbra packages individually

Install/Upgrade zimbra-proxy-components on Proxy node for FOSS and NETWORK

  • As root, first clear the yum cache and check for updates so the server sees all updated packages in the patch repository:
yum clean metadata
yum check-update
  • Then install the package:
yum install zimbra-proxy-components
  • Restart proxy as zimbra user:
su - zimbra
zmproxyctl restart

Install/Upgrade zimbra-proxy-patch on Proxy node for FOSS and NETWORK

  • As root, install the package:
yum install zimbra-proxy-patch
  • Restart proxy as zimbra user:
su - zimbra
zmproxyctl restart
zmmemcachedctl restart

Install/Upgrade zimbra-mta-components on MTA node for FOSS and NETWORK

  • As root, first clear the yum cache and check for updates so the server sees all updated packages in the patch repository:
yum clean metadata
yum check-update
  • Then install the package:
yum install zimbra-mta-components
  • Restart amavisd as zimbra user:
su - zimbra
zmamavisdctl restart

Install/Upgrade zimbra-mta-patch on MTA node for FOSS and NETWORK

  • As root, install the package:
yum install zimbra-mta-patch
  • Restart amavisd as zimbra user:
su - zimbra
zmamavisdctl restart

Install/Upgrade zimbra-patch on mailstore node for FOSS and NETWORK

  • As root, install the package:
yum install zimbra-patch
  • Restart ZCS as zimbra user:
su - zimbra
zmcontrol restart

Install/Upgrade zimbra-talk and zimbra-network-modules-ng (NETWORK Only)

  • As root, first clear the yum cache and check for updates so the server sees all updated packages in the patch repository:
yum clean metadata
yum check-update
  • Then install the packages:
yum install zimbra-network-modules-ng
yum install zimbra-talk
  • Restart Zimbra mailbox service as zimbra user:
su - zimbra
zmmailboxdctl restart

Install/Upgrade zimbra-docs (NETWORK Only)

  • As root, install the package:
yum install zimbra-docs
  • Restart Zimbra mailbox service as zimbra user:
su - zimbra
zmmailboxdctl restart

Install/Upgrade zimbra-drive-ng (NETWORK Only)

  • As root, install the package:
yum install zimbra-drive-ng
  • Restart Zimbra mailbox service as zimbra user:
su - zimbra
zmmailboxdctl restart

Install/Upgrade Modern Web App Zimlets (NETWORK Only)

  • Please refer here for installing zimlets for Modern Web App.


Upgrade OpenLDAP on LDAP node for FOSS and NETWORK

  • As root, install the package:
yum install zimbra-ldap-components
  • Restart ldap as zimbra user:
su - zimbra
ldap restart

Ubuntu

Installing zimbra packages with system package upgrades

  • As root, check for updates so the server sees there is a new zimbra-patch package in the patch repository:
apt-get update
  • Then update available packages:
apt-get upgrade

OR

  • Update all available packages plus any kernel updates:
apt-get dist-upgrade
  • Restart ZCS as zimbra user:
su - zimbra
zmcontrol restart

Installing zimbra packages individually

Install/Upgrade zimbra-proxy-components on Proxy node for FOSS and NETWORK

  • As root, install package
apt-get install zimbra-proxy-components
  • Restart proxy as zimbra user:
su - zimbra
zmproxyctl restart

Install/Upgrade zimbra-proxy-patch on Proxy node for FOSS and NETWORK

  • As root, install package
apt-get install zimbra-proxy-patch
  • Restart proxy as zimbra user:
su - zimbra
zmproxyctl restart
zmmemcachedctl restart

Ubuntu 18 zimbra-proxy-patch version

zimbra-proxy-patch        ->  8.8.12.1554984827.p3-1

The installation of this patch is mandatory for the proxy to function on Ubuntu 18 servers.

Install/Upgrade zimbra-mta-components on MTA node for FOSS and NETWORK

  • As root, install package
apt-get install zimbra-mta-components
  • Restart amavisd as zimbra user:
su - zimbra
zmamavisdctl restart

Install/Upgrade zimbra-mta-patch on MTA node for FOSS and NETWORK

  • As root, install package
apt-get install zimbra-mta-patch
  • Restart amavisd as zimbra user:
su - zimbra
zmamavisdctl restart

Install/Upgrade zimbra-patch on mailstore node for FOSS and NETWORK

  • As root, check for updates and install package:
apt-get update
apt-get install zimbra-patch
  • Restart ZCS as zimbra user:
su - zimbra
zmcontrol restart

Install/Upgrade zimbra-talk and zimbra-network-modules-ng (NETWORK Only)

  • As root, check for updates and install packages:
apt-get update
apt-get install zimbra-network-modules-ng
apt-get install zimbra-talk
  • Restart Zimbra mailbox service as zimbra user:
su - zimbra
zmmailboxdctl restart

Install/Upgrade zimbra-docs (NETWORK Only)

  • As root, install package:
apt-get install zimbra-docs
  • Restart Zimbra mailbox service as zimbra user:
su - zimbra
zmmailboxdctl restart

Install/Upgrade zimbra-drive-ng (NETWORK Only)

  • As root, install package:
apt-get install zimbra-drive-ng
  • Restart Zimbra mailbox service as zimbra user:
su - zimbra
zmmailboxdctl restart

Install/Upgrade Modern Web App Zimlets (NETWORK Only)

  • Please refer here for installing zimlets for Modern Web App.


Upgrade OpenLDAP on LDAP node for FOSS and NETWORK

  • As root, install the package:
apt-get install zimbra-ldap-components
  • Restart ldap as zimbra user:
su - zimbra
ldap restart
Jump to: navigation, search