Difference between revisions of "SMTP Auth Problems"

Line 22: Line 22:
  
 
4. Make sure the url in the AuthURL will work with the MailMode. For example, if the AuthURL begins with "https://" (auth will be attempted over ssl) but the MailMode is "http" (tomcat is only listening on http), the authentication will fail.
 
4. Make sure the url in the AuthURL will work with the MailMode. For example, if the AuthURL begins with "https://" (auth will be attempted over ssl) but the MailMode is "http" (tomcat is only listening on http), the authentication will fail.
 +
 +
If the URL is wrong (in my case it was http:// rather than https://), simply re-set the hostname like this:
 +
zmprov ms mail.mydomain.com zimbraMtaAuthHost mail.mydomain.com

Revision as of 11:38, 2 October 2006

SMTP Authentication allows POP3 and IMAP clients to send mail from arbitrary remote networks. If POP3 and IMAP clients are unable to send mail, check the auth settings and mail mode of the server:

Authentication also fails if you changed the port for the tomcat server, since the zimbraMtaAuthURL is not recreated when the port is changed. Solution is to force the recreation using the command in 3 below.

$ su - zimbra
$ zmprov gs zimbra.domain.com | grep Auth
zimbraMtaAuthEnabled: TRUE
zimbraMtaAuthHost: zimbra.domain.com
zimbraMtaAuthURL: https://zimbra.domain.com:443/service/soap/
zimbraMtaTlsAuthOnly: TRUE

$ zmprov gs zimbra.domain.com | grep Mode
zimbraMailMode: mixed

1. In order to use smtp authentication, zimbraMtaAuthEnabled must be set to TRUE

2. If zimbraMtaTlsAuthOnly is also TRUE, the POP3 and IMAP clients must be configured to use ssl/tls for smtp auth.

3. In a multi-node installation, make sure that zimbraMtaAuthHost and zimbraMtaAuthURL are set to a mailbox server. If not, the command "zmprov ms zimbra.domain.com zimbraMtaAuthHost mailbox.domain.com" will set them appropriately.

4. Make sure the url in the AuthURL will work with the MailMode. For example, if the AuthURL begins with "https://" (auth will be attempted over ssl) but the MailMode is "http" (tomcat is only listening on http), the authentication will fail.

If the URL is wrong (in my case it was http:// rather than https://), simply re-set the hostname like this: zmprov ms mail.mydomain.com zimbraMtaAuthHost mail.mydomain.com

Jump to: navigation, search