MacUpgradeBug

Revision as of 00:16, 15 June 2006 by MergeSpamAccountsIntoMe (talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

Mac Upgrade Bug

Overview

Occasionally, the package installation on the Mac platform incorrectly determines that it's performing an "Install" as opposed to an "Upgrade".

Workaround

If this happens to you, follow the following procedure

  • Complete the package installation - DO NOT RUN /opt/zimbra/libexec.pl
  • run (as zimbra)
/opt/zimbra/libexec/zmslapcat /tmp/ldap_backup
  • Prior to running /opt/zimbra/libexec.pl, edit the file /opt/zimbra/.install_history
The last section that looks like this

1150314534: INSTALL SESSION START
1150314536: INSTALLED zimbra-core-3.1.2_GA_445.pkg
1150314537: INSTALLED zimbra-ldap-3.1.2_GA_445.pkg
1150314547: INSTALLED zimbra-store-3.1.2_GA_445.pkg
1150314554: INSTALLED zimbra-mta-3.1.2_GA_445.pkg
1150314558: INSTALLED zimbra-apache-3.1.2_GA_445.pkg
1150314559: INSTALLED zimbra-spell-3.1.2_GA_445.pkg
1150314563: INSTALL SESSION COMPLETE
  • change instances of INSTALLED to UPGRADED
1150314534: INSTALL SESSION START
1150314536: UPGRADED zimbra-core-3.1.2_GA_445.pkg
1150314537: UPGRADED zimbra-ldap-3.1.2_GA_445.pkg
1150314547: UPGRADED zimbra-store-3.1.2_GA_445.pkg
1150314554: UPGRADED zimbra-mta-3.1.2_GA_445.pkg
1150314558: UPGRADED zimbra-apache-3.1.2_GA_445.pkg
1150314559: UPGRADED zimbra-spell-3.1.2_GA_445.pkg
1150314563: INSTALL SESSION COMPLETE
  • run /opt/zimbra/libexec/zmsetup.pl
Jump to: navigation, search