IPv6 Issue with zimbra-proxy

Revision as of 14:24, 30 August 2018 by Shanxt (talk | contribs) (IPv6-Issue with zimbra-proxy)

Proxy services fails to start if IPv6 is enabled


   KB 23336        Last updated on 2018-08-30  




0.00
(0 votes)


Problem

Tried to enable IPv6 with the following command :

zmprov ms `zmhostname` zimbraIPMode both

While running the zmcontrol restart got the following error :

Starting proxy...Failed. 
Starting nginx...nginx: [emerg] bind() to [::]:7143 failed (98: Address already in use) 
nginx: [emerg] bind() to [::]:7993 failed (98: Address already in use) 
nginx: [emerg] bind() to [::]:7110 failed (98: Address already in use) 
nginx: [emerg] bind() to [::]:7995 failed (98: Address already in use)

Solution

Follow the below steps to enable IPv6 :

1). Run as zimbra user :

su - zimbra 
zmprov ms `zmhostname` zimbraIPMode both

2). Run this command

/opt/zimbra/libexec/zmiptool

Then try restart the zimbra services :

zmcontrol restart
Verified Against: ZCS 8.8, 8.7, 8.6 Date Created: 2018-08-13
Article ID: https://wiki.zimbra.com/index.php?title=IPv6_Issue_with_zimbra-proxy Date Modified: 2018-08-30



Try Zimbra

Try Zimbra Collaboration with a 60-day free trial.
Get it now »

Want to get involved?

You can contribute in the Community, Wiki, Code, or development of Zimlets.
Find out more. »

Looking for a Video?

Visit our YouTube channel to get the latest webinars, technology news, product overviews, and so much more.
Go to the YouTube channel »


Jump to: navigation, search