Amavisd not starting after upgrade from v8.0.x to higher versions(8.5.x,8.6.x and 8.7.x)

Revision as of 08:13, 17 July 2017 by Heera Singh Koranga (talk | contribs) (Created page with " Problem : After upgrade Amavisd not starting and zimbra.log shows below errors. <nowiki>------------------------------------------------------------------------------</no...")

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

Problem :

After upgrade Amavisd not starting and zimbra.log shows below errors.

------------------------------------------------------------------------------

Not able to start Amavis services, error :

Dec 21 10:02:29 server amavis[7787]: initializing Mail::SpamAssassin (0)

Dec 21 10:02:29 server amavis[7787]: (!!)TROUBLE in pre_loop_hook: config: no rules were found! Do you need to run 'sa-update'?

Dec 21 10:02:29 server amavis[7787]: (!)_DIE: Suicide () TROUBLE in pre_loop_hook: config: no rules were found! Do you need to run 'sa-update'?

------------------------------------------------------------------------------


Solution :

If the server is having Internet access then below sa-update will resolve the issue :

su – zimbra /opt/zimbra/zimbramon/bin/sa-update -D   zmamavisdctl restart


If ZCS server is in DMZ or isolated network :

  • Check “state” directory in “/opt/zimbra/data/spamassassin/”.
  • If “state” directory is present then move it to some other location and restart Amavisd service.


mv /opt/zimbra/data/spamassassin/state /tmp/state zmamavisdctl restart

Jump to: navigation, search