Difference between revisions of "Amavisd not starting after upgrade from v8.0.x to higher versions(8.5.x,8.6.x and 8.7.x)"

(Created page with " Problem : After upgrade Amavisd not starting and zimbra.log shows below errors. <nowiki>------------------------------------------------------------------------------</no...")
 
Line 1: Line 1:
 +
 +
 +
= Amavisd_not_starting_after_upgrade_from_v8.0.x_to_higher_versions(8.5.x,8.6.x_and_8.7.x) =
  
 
Problem :  
 
Problem :  
Line 5: Line 8:
  
 
<nowiki>------------------------------------------------------------------------------</nowiki>
 
<nowiki>------------------------------------------------------------------------------</nowiki>
 
 
Not able to start Amavis services, error :  
 
Not able to start Amavis services, error :  
 
 
Dec 21 10:02:29 server amavis<nowiki>[7787]: initializing Mail::</nowiki>SpamAssassin (0)  
 
Dec 21 10:02:29 server amavis<nowiki>[7787]: initializing Mail::</nowiki>SpamAssassin (0)  
 
 
Dec 21 10:02:29 server amavis<nowiki>[7787]: (!!)TROUBLE in </nowiki>pre_loop_hook: config: no rules were found! Do you need to run 'sa-update'?  
 
Dec 21 10:02:29 server amavis<nowiki>[7787]: (!!)TROUBLE in </nowiki>pre_loop_hook: config: no rules were found! Do you need to run 'sa-update'?  
 
 
Dec 21 10:02:29 server amavis<nowiki>[</nowiki>7787]: (!)_DIE: Suicide () TROUBLE in pre_loop_hook: config: no rules were found! Do you need to run 'sa-update'?
 
Dec 21 10:02:29 server amavis<nowiki>[</nowiki>7787]: (!)_DIE: Suicide () TROUBLE in pre_loop_hook: config: no rules were found! Do you need to run 'sa-update'?
 
 
<nowiki>------------------------------------------------------------------------------</nowiki>
 
<nowiki>------------------------------------------------------------------------------</nowiki>
  

Revision as of 08:16, 17 July 2017


Amavisd_not_starting_after_upgrade_from_v8.0.x_to_higher_versions(8.5.x,8.6.x_and_8.7.x)

Problem :

After upgrade Amavisd not starting and zimbra.log shows below errors.

------------------------------------------------------------------------------ Not able to start Amavis services, error : Dec 21 10:02:29 server amavis[7787]: initializing Mail::SpamAssassin (0) Dec 21 10:02:29 server amavis[7787]: (!!)TROUBLE in pre_loop_hook: config: no rules were found! Do you need to run 'sa-update'? Dec 21 10:02:29 server amavis[7787]: (!)_DIE: Suicide () TROUBLE in pre_loop_hook: config: no rules were found! Do you need to run 'sa-update'? ------------------------------------------------------------------------------


Solution :

If the server is having Internet access then below sa-update will resolve the issue :

su – zimbra /opt/zimbra/zimbramon/bin/sa-update -D   zmamavisdctl restart


If ZCS server is in DMZ or isolated network :

  • Check “state” directory in “/opt/zimbra/data/spamassassin/”.
  • If “state” directory is present then move it to some other location and restart Amavisd service.


mv /opt/zimbra/data/spamassassin/state /tmp/state zmamavisdctl restart

Jump to: navigation, search