Upgrading Zimbra from RHEL4 to RHEL5

From Zimbra :: Wiki

Jump to: navigation, search
Admin Article

Article Information

This article applies to the following ZCS versions.
  ZCS 4.5 Article  ZCS 4.5

Introduction

Zimbra Collaboration Suite 4.5.6 is the first version of ZCS that provides support on the Red Hat Enterprise Linux 5 (RHEL5) platform. This article describes the high level procedures in upgrading an existing ZCS installation from RHEL4 to RHEL5.
Note: We currently don't support RedHat Cluster (RHCS) on RHEL5. There is currently no date to support it.

Procedures

1. Upgrade to ZCS 4.5.6 (build 1044) RHEL4/RHEL4_64.
2. Run the following command as root,

chkconfig zimbra off

3. Make sure that the Security Enhanced Linux (SELinux) is disabled by setting the following in /etc/selinux/config:

SELINUX=disabled

4. Upgrade the Operating System to RHEL5/RHEL5_64 by selecting the "Upgrade an existing installation" option.
5. Upgrade ZCS to 4.5.6 (build 1044) RHEL5/RHEL5_64.

Ignore the following error:

Backing up ldap
/opt/zimbra/openldap/sbin/slapcat: error while loading shared libraries: libssl.so.4: cannot open shared object file: No such file or
directory
Verified Against: Zimbra Collaboration Suite 4.5.6 Date Created: 7/28/2007
Article ID: http://wiki.zimbra.com/index.php?title=Upgrading_Zimbra_from_RHEL4_to_RHEL5 Date Modified: 04/16/2010
Personal tools